Ciao a tutti,

per una serie di cose verificatesi in concomitanza, questa mattina ho deciso di aggiornare il sistema operativo di Linux Ubuntu, installando la nuova versione descritta in oggetto.

Non desideravo installare una nuova serie di partizioni ma ho voluto vedere cosa sarebbe accaduto aggiornando la versione esistente (Ubuntu 7.10) alla nuova edizione.

Beh, i tempi di scaricamento sono stati abbastanza ridotti e tutto si è svolto nel migliore dei modi.
L’inizio dell’installazione si è svolto senza errori di alcun genere ma poi…

… sono iniziati i problemi, poi successivamente risolti!!

L’ambiente grafico che uso normalmente è Gnome e mi ci trovo magnificamente!!

Durante l’installazione si sono verificati degli errori non spiegabili, in quanto l’installatore si è rifiutato inizialmente di installare tutto il nuovo ambiente Gnome, assieme a altri programmi.

Al termine dell’installazione ho dovuto provvedere a sistemare le cose ‘a manina’, risolvendo l’installazione di :

  • gnome control center
  • scrollkeeper
  • gnome terminal
  • gnome applets data
  • gnome panel
  • gnome applets
  • gucharmap
  • nautilus data
  • nautilus cd burner
  • nautilus share
  • gedit
  • alacarte
  • doc base
  • fast user switch applet
  • synaptic
  • gnome app install
  • gnome system monitor
  • language selector
  • nautilus send to
  • update manager
  • update notifier
  • ubuntu desktop
  • gnome rdp
  • nautilus image converter
  • nautilus script audio

Questo è molto strano, in quanto non si era mai verificato in altre identiche installazioni effettuate su altri PC dei miei amici. Comunque, rimboccandosi le maniche e dopo circa 3o ulteriori minuti di pazienza, ho risolto il tutto.

La parte Xorg è stata il resto dello scempio. Infatti l’installazione funzionante che girava benissimo sulla versione 7.10, la vecchia versione e i suoi file di configurazione sono stati falciati e sostituiti da un file di configurazione molto generalizzato. Anche qui ho dovuto provvedere a sistemare ‘a manina’, perdendo altro tempo. Sarebbe stato molto bello se ciò non fosse accaduto e la nuova versione avesse potuto usare il vecchio file di configurazione, che avevo accuratizzato al meglio.

Molti applicativi esterni alla normale installazione hanno perso la localizzazione in italiano, che provvederò a sistemare ‘a manina’ man mano che mi serviranno. Ci vorrà dell’altro tempo….

Questa volta l’upgrade è stato abbastanza veloce

60 min. per il download dei file,

90 min. per l’installazione…

… ma mi ha lasciato parecchie cose da sistemare.

Lasciamo perdere il discorso di Firefox, che ho dovuto (come tutti voi …) sistemare al meglio, in quanto ci faccio girare circa 30 plugin differenti, che ho sistemato man mano che mi servivano. La mia configurazione del browser è molto particolare e non è stata ben accettata dalla versione beta 3.0 di FF.

Mi resta da applicare il driver proprietario ATI per la mia scheda video, ATI Mobility Radeon 9700, che cose sempre (veramente SEMPRE…) mi danno filo da torcere per far funzionare al meglio la mia scheda grafica. Ora non uso Compiz e non ho il 3D… ma sto usando il driver di Ubuntu.

Dopo tutto questo, anche Scribus è passato ad una nuova sub versione, che spero non mi crei problemi durante l’edizione della rivista FCM in lingua italiana. Ora gira la versione 1.3.3.11.

Man mano che sistemo questa nuova versione del sistema operativo di Linux Ubuntu, aggiornerò questo post in modo da aiutare chi ha avuto i miei stessi problemi…

Un saluto,

Paolettopn

Riguardo a: paolettopn

Anticonformista, sempre_quarantenne, nato sotto il segno dell'acquario, appassionato di informatica ed elettronica sin dalla tenera età, usa software linux, open-source e oggi si diverte e lavora con le telecomunicazioni l'elettronica e l'informatica. Il resto delle informazioni lo potete trovare sul wiki della Comunità italiana di Ubuntu-it. Ciao, a presto.

5 thoughts on “Passaggio a Hardy Heron 8.04.

  1. Io invece proprio ieri ho dovuto reinstallare tutto da capo grazie ad un aggiornamento che mi ha riscritto il mio xorg.conf, da me, all’epoca costruito a manina. D’ora in poi, prima di passare gli aggiornamenti farò un’immagine della partizione root.
    Ma così non va mica bene 🙁

  2. A me, invece su un’installazione 7.10 abbastanza semplice (non avevo configurazioni particolari e personalizzate) ha aggiornato tutto velocemente e senza problemi. L’8.04 ha funzionato subito perfettamente ed al primo colpo…. Evidentemente l’aggiornamento non “gradisce” configurazioni particolarmente personalizzate… Comunque poi, per fissazione mia (mi piace vedere come esce e come si presenta la distribuzione “di serie”), ho reinstallato, cancellando tutto, la 8.04 ed anche in questo caso ottimo risultato con un riconoscimento hardware che non ha sbagliato 1 colpo…

  3. Quoto in tutto la procedura di installazione della 8.04 sul mio fidato Acer 1672WLMi dotato della “maledetta” ATI Mobility Radeon 9700/64MB.
    anche se faccio lspci -v ho:
    01:05.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10] (prog-if 00 [VGA])
    Subsystem: Acer Incorporated [ALI] Unknown device 0065
    Flags: bus master, fast Back2Back, 66MHz, medium devsel, latency 66, IRQ 16
    Memory at f0000000 (32-bit, prefetchable) [size=128M]
    I/O ports at 9000 [size=256]
    Memory at e8100000 (32-bit, non-prefetchable) [size=64K]
    [virtual] Expansion ROM at e8120000 [disabled] [size=128K]
    Capabilities:

    Mobility Radeon 9600 M10? 9600 o 9700?

    Tornando al tuo post, stessi tempi per il download dell’aggiornamento dalla 7.10 e stessi tempi per l’installazione. Stessi problemi risolti manualmente per un sacco di installazioni.

    Ma il dramma è stato nell’attivazone di Compiz-Fusion su Gnome. Non posso attivare nessun effetto grafico. Ciò che funzionava egregiamente nella 7.10 non funziona nella 8.04. Il 3D è un sogno sulla 8.04, mentre era perfetta realtà nella 7.10. Come è possibile? mi ricorda certe cose sentite fra Vista e XP…. ma qui siamo in Linux, fra persone serie, mica in Windows….

    Sto provando da settimane con ogni mezzo, ma niente… la 8.04 è una delusione da questo punto di vista.
    Ho provato di tutto:
    . abilitare driver proprietari ATI fgrlx (schermo nero, o bianco, a seconda dell’umidità ambiententale);
    . riconfigurare X.org sulla base delle 7.10 (meno male che c’è la possibilità di resettare tutto…);
    . Envy installato, ma risultati sono schermo nero il mercoledì e sabato (solo se non piove), il resto della settimana nemmeno mi fa il boot;
    . provato tutti i suggerimenti di Wiki Italia e English, ma niente…

    Mi rimane di:
    . portare il portatile a Lourdes e immergere la scheda grafica nell’acqua miracolosa;
    . Far bollire il tutto nel latte e grappa con foglie di alloro e gocce di acqua santa;
    . esorcismo praticato ai piedi dell’Himalaya presenti il Dalai Lama e Vanna Marchi;
    . aspettare che ATI-AMD rilasci driver funzionanti.

    Peccato. Grazie alla 7.10 mi sono innamorato di Linux e di Ubuntu, ho convertito una decina di conoscenti a passare ad Ubuntu. Mi sembra di essere tornato a 20 anni fa, quando con peek e poke programmavo a basso livello il mio C64. Quando si era padroni della propria macchina… Quando si era liberi di scegliere. Bei tempi.
    Ma noi lo sappiamo bene… per l’utente medio, se non si fa girare il cubo di CompizFusion e non si mostra le finestre gommose non c’è tanta possibilità di convincere a mollare Windows.
    Che facciamo?
    Keep in touch. fammi sapere se ci sono progressi nella risoluzione del problema. io farò altrettanto.

    Ciao e buon lavoro

  4. Ciao Franz,

    devi sapere che non avevo il tempo di installare i driver per ottenere il 3D con la mia nota scheda video, ma l’altro ieri dopo aver aggiornato Hardy e installato il nuovo kernel ho attivato i driver con restrizioni, ottenendo un buon livello di 3D e riuscendo ad attivare molte delle funzioni di Compiz.

    Attento, in Effetti visivi, ho attivato la modalità normale e tutto si è accomodato da se !! Incredibile… ma vero!

    Spero che a te possa accadere la stessa cosa e che tu possa risolvere il tedioso problema del video 3D.

    Un saluto,

    Paolettopn

Lasciate un vostro commento a questo post